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Getting Started with Moodle 

 

After entering a course, edit by clicking the Turn editing on button in the upper-right corner. 

 

Editing icons: 

 Hand with pencil icon: Edit 

 X: Delete content 

 Eyeball: Hide content form students 

 Directional arrows: Move content 

 

While editing go to the Switch role to dropdown menu in the upper-right corner in order to view the page from 

another’s point of view. 

 

Edit personal profile: Click on name in the upper-right corner. 

 

Change course format, or number of weeks/topics, start date, etc.: Administration block > Settings 

 

Editing the header block: Edit the top block once editing is turned on. 

 

Add a document, such as a course syllabus, through the Add a resource dropdown menu. All documents, along 

with summary, are posted under Administration block > Activities > Resources.  

 

When posting documents, use Force Download in order for automatic download to take place once a file has 

been selected. This is a good idea. 

 

When a new topic is added under the News forum, it is automatically sent to all students in the class. 

 

Students can access the News forum in the header block, as well as reply to posts. 

 

Upload multiple files at the same time: Administration block > Files 

 

Folders can be created for organizational purposes. To upload to a specific folder, open the folder and then 

upload. 

 

Post file to a specific week: Go to week and click Add a resource button 

 

Set up grade book: Administration block > Grades. All enrolled students will already be listed. To make 

changes, go to the Choose an action dropdown menu in the top-left corner. 

 

Go to main grade section: Administration Block > Grades > Choose an action dropdown menu > Grader report 

 

Send mass email: People block > Participants 

 

Create a simple assignment to a specific content block: Go to proper content block > Add an activity dropdown 

menu > Assignments > online text. Assignment will appear under content block as well as Activities > 

Assignments. Student submissions will be listed in the assignments section.  

 

Posted assignments are automatically added to the grade book. 
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The HTML Editor 

 

HTML editor, Enlarge Editor button: Located on the bottom row, to the far right. Clicking on this also gives the 

user a whole new row of tools to use with tables. 

 

Tables: Add and delete columns and rows by using arrows and circles that appear once the initial table has been 

created. 

 

Anchors: Select destination text > click Anchor button > name > select linking text > click Insert Web Link 

button > select proper anchor 

 

When inserting an image, make sure to always add alternate text.  

 

Working with Media 

 

Use Photoshop to reduce the size of images and get them ready for Moodle. 

 

Batch upload files: First, compress files/images > Administration block > Files > upload zip file > unzip 

 

Post link to image within course block: Add a resource dropdown menu > Link to a file or website 

 

Posting a photo gallery, audio, or video: Add a resource dropdown menu > Link to a file or website 

 

Compressing video file for Moodle: Create Quicktime 

 

Default movie files supported: .mov, .FLV, wmv 

 

Resources 

 

Creating a text label (title at the top of a block): Edit summary icon (hand with pencil icon) > make changes. 

Use heading options. 

 

Create category for files (organize files by category, with each category specified by a heading) (All of this 

appears directly under the text label): Add a resource dropdown menu > Insert a label. Use heading options.  

 

Insert picture directly on page: Add a resource dropdown menu > Insert a label > click inside HTML editor and 

insert image with the Insert Image button 

 

Create website link directly on page: Add a resource dropdown menu > Link to a file or website. Paste link into 

Link to a file or website. 

 

Create a text page: Add a resource dropdown menu > Compose a text page 

 

Create a webpage: Add a resource dropdown menu > Compose a webpage 

 

Linking to a folder of documents: Administration block > Files > upload zip file to a folder > unzip. Add a 

resource dropdown menu > Display a directory 

 

Assignments 
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Have grade book set up before issuing assignments. 

 

Assignments: Can be found under the Add an activity dropdown menu 

 

Change an assignment once it has been posted: Go into the assignment and click on the Update this Assignment 

button in the upper-right corner. 

 

Activities  

 

Create a live chat room: Add an activity dropdown menu > Chat 

 

Creating a choice (survey): Add an activity dropdown menu > Choice 

 

Databases 

 

Setting up a database: Add an activity dropdown menu > Database 

 

After setting up a database, data fields must be entered (titles of spreadsheet columns/rows): Open database > 

Fields tab > Create a new field dropdown menu > Choose > Text 

 

Customizing a database template: Open database > Templates tab. Once the template is saved, go to the View 

list tab in order to see a listing of all entries inside of the database.  

 

Entering data into a database: Enter database > Add entry tab 

 

Enable database auto-linking: Log in with administration account > Site Administration block > Modules > 

Filters > Manage filters. This means that whenever a name from the database appears in the website, the website 

automatically links the name back to the database. 

 

File uploading to database: Open database > Fields tab > Create a new field dropdown menu > File > Enter 

Field name and Field description > Add button > Templates tab > Save template button > go to Add entry tab to 

see that students can now upload files when adding an entry.  

 

Glossaries 

 

Creating a main glossary for the entire site: In the header block, go to Add an activity dropdown menu > 

Glossary. When setting options, each course can only have one Main glossary. 

 

Add concepts to the glossary: Open glossary > Add a new entry button. At this point, a file can also be added to 

the concept, as well as auto-linking. 

 

Enable auto-linking for website: Log in with administration account > Site Administration block > Modules > 

Filters > Manage filters 

 

Allow students to edit glossary information (not just adding comments): Enter glossary > Update this Glossary 

button in upper-right corner > Locally assigned roles tab > Non-editing teacher > promote students to non-

editing teacher 

 

Create a secondary glossary (may contain information other than definitions, which are located in the main 

glossary): In the header block, go to Add an activity dropdown menu > Glossary > under the options, make it a 
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Secondary glossary > select auto-linking. After creation, references/terms throughout the website will link 

back to the secondary glossary. 

 

Forums 

 

Create a forum: Add an activity dropdown menu > Forum 

 

Forum types: 

 Standard forum for general use: Initial thread or question is created, and then other users can respond 

 A single simple discussion: One discussion thread for forum 

 Each person posts one discussion: Every user can post an initial question or thread, and then people can 

respond to each other. 

 Q and A forum: You can post a question and students can respond to it. 

 

Attachments can be made to responses to forums. Teachers can add comments to attachments and then repost 

them.  

 

Wiki 

 

Create a wiki: Add an activity dropdown menu > Wiki. Click Show Advanced button in order to open up 

additional options. 

 

Different types of wikis (selectable under options): 

 Groups: All students can collaboratively build a group wiki. The group will be defined by the entire 

class of students/all users. 

 Student: Each student will have their own wiki that they can privately create, but they won’t be able to 

collaborate within other students within the course. 

 Teacher: The teacher has access to create content, but the students do not. 

 

In a wiki, add 3, 2, or 1 (3 = biggest) exclamation point(s) before a line in order to turn the line into a heading. 

 

Enclose a line with square brackets in order to have it link to another page within the wiki. After, in View mode, 

click on the question mark next to the link in order to create the page to which it links.  

 

To create a list, use asterisks (1 = level 1, 2 = level 2, etc.). 

 

# sign before a list gives it numbers instead of bullets, which is what asterisks do 

 

# and * can be used in conjunction with square brackets. 

 

Use two single quotation marks (‘‘) before and after a word to italicize it. 

 

Attaching images: Go to the Attachments tab. The file will be attached, not embedded. 

 

Embedding images: Once it is attached, right-click on the link and then copy its location to the clipboard. Paste 

the link – surrounded by square brackets – into the wiki. 

Create an external link to website: [text you want reader to see | link] 

 

Creating a table 
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Assessing Learners with Tests and Quizzes 

 

Access question bank: Administration block > Questions 

 

Create different categories under which questions will fall: Administration block > Questions > Categories tab. 

Type in a name > Add category button. To create sub-categories, go to the appropriate parent category and then 

enter a name. 

 

Create questions: Administration block > Questions > Questions tab > Create new question dropdown menu 

 Images to display: Select any image that has already been uploaded into the files and folders section of 

the course. (image will be seen once the question is previewed) 

 An image can also be added to a question by inserting it right into the HTML editor by using the Insert 

Image icon. 

 

Preview a question: Under the questions tab, click the magnifying glass that is located to the left of the question 

name. 

 

Prevent auto-linking within a question: While editing the question, select term > Prevent automatic linking icon 

 

Using a sound clip as a possible answer for a multiple-choice question: In HTML editor, type text > Insert web 

link icon (to link to a sound file) > Toggle HTML Source icon > cut and paste code into answer  > Toggle 

HTML Source icon 

 

With multiple-choice questions, wrong answers should have a grade of None, and correct answers should have 

an answer of 100%. 

 

For match questions, insert an image as a question: Insert the image into HTML editor with the Insert Image 

icon > Toggle HTML Source icon > cut and paste code into a question > Toggle HTML Source icon 

 

Creating a quiz: Add an activity dropdown menu > Quiz 

 

Once quiz is created, go to block and click on exam in order to add questions to it. Preview the quiz by clicking 

on the Preview tab. 

 

Grades 

 

Grade book: Administration block > Grades 

 

Access assignments as a student: Activities block > Assignments 

 

Access grades: Administration block > Grades 

 

Grade/View a submitted assignment: Activities block > Assignments > click on name of assignment 

 

Quick grading: Activities block > Assignments > View submitted assignments > Allow quick grading checkbox 

> Save preferences > grade 

 

Detailed view of a student’s performance on an assessment: In grade book, click on student’s grade. 
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Grade an essay/subjective question: In grade book, click on student’s score (or lack thereof) for the question > 

Make comments or override grade > grade 

 

Item analysis: Grade book > Item analysis (top-right, just below the tabs) 

 

Click on a column header to sort data by that specific header. 

 

For information about each column header within the item analysis, click on the question mark icon next to 

“Item Analysis Table” (top-left) 

 

Create new assignment from inside of the grade book: Grade book > choose an action dropdown menu (top-left) 

> Categories and items > Add grade item button 

 

Export grade book to Excel: Grade book > Choose an action dropdown menu (top-left) > Excel spreadsheet > 

customize > Submit button > Download button 

 

Import grades from Excel: In Excel, File menu > Save As. Format should be “Comma separated Values (.csv)” 

(might also be either “Windows” or “MS-DOS”, depending on server). In Moodle, Grade book > Choose an 

action dropdown menu > CSV file > Browse for file > customize (for encoding UTF-8 should be fine, but might 

need to be changed depending on server) > Upload grades button > customize (for Grade item mappings, pick 

what you want to display in grade book, and choose its corresponding grade item in its dropdown menu) > 

Upload grades button 

 

Calendars and Events 

 

Access calendar: Upcoming Events block > Go to calendar 

 

When exporting an iCal calendar with the Export button, save it to the desktop and then open it. This is a one-

time sync.  

 

Enable automatic syncing between Moodle calendar and iCal: When exporting calendar, click Get calendar 

URL button > copy URL > In iCal, go to calendar menu > Subscribe > paste URL 

 

Exporting Moodle Calendar to Outlook: Use Export button > Open with Outlook. This is a one-time sync. 

 

Enable automatic syncing between Moodle calendar and Outlook: When exporting calendar, click Get calendar 

URL button > Copy URL > In Outlook, Tools menu > Account Settings > Internet Calendars tab > New button 

> Paste URL 

 

Course Management 

 

Assign roles (non-editing teacher, student, or guest): Administration block > Assign roles 

 

Non-editing teacher capabilities are controlled by the Moodle administration. 

 

Managing group: Administration block > Groups 

 

Backing up your course: Administration block > Backup > customize > Continue button > Continue button > 

Continue button > click on file and save to hard drive 
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Restore data from a backup: Administration block > Restore > choose file > Restore > Yes button > Continue 

button > customize > Continue button > Restore this course now! button > Continue button 

 

Import information from another course: Administration block > Import > choose course from which to import 

> Use this course button > customize > Continue button > Continue button > Continue button > Continue button 

 

Reset a course: Administration block > Reset > customize > Reset course button > Continue button 

 

Running Reports: Administration block > Reports > customize > Get these logs button. The links as the bottom 

of the Reports page can also be used. Student profiles and activity can be found under Participation report. 

 

Conclusion 

 

“Moodle Docs for this page” link (bottom-left of page) is an online manual that provides users with support and 

information. Log in (top-right of manual) for more information.  

 

 

 

 

 

 


